رفع خطای "Unable to determine bundled Java version" در فلاتر (یک راهکار ساده)

رفع خطای Unable to determine bundled Java version در فلاتر (یک راهکار ساده)

Written by:

مشکل چیه؟

تو این مقاله به راه‌حلی برای “رفع خطای Unable to determine bundled Java version “در زمان اجرای دستور flutter doctor می‌پردازیم.
زمانی که شما از دستور “flutter doctor” استفاده می‌کنید، یکی از خطاهای رایج “Unable to determine bundled Java version” هست.

Unable to determine bundled Java version

راهکار

خوب اولش مطمئن باشید یک نسخه از JDK و Android Studio رو نصب کرده باشید، بعد مراحل زیر و پیش برید:

1- به مسیر C:\Program Files\Android\Android Studio برید.
2- محتویات پوشه jbr را کپی کنید.
3- محتویات کپی شده را در پوشه jre بریزید.

الان دوباره دستور “flutter doctor” رو اجرا کنید، احتمالا مشکلتون حل شده باشه.

این کار باعث میشه نسخه Java که برای Flutter استفاده میشه، توسط سیستم هم تشخیص داده بشه و پروژه‌های Flutter بدون خطا اجرا کنید.

نتیجه نهایی تقریبا اینجوری میشه:

flutter doctor fix

 

جمع‌بندی

زمان نصب فلاتر مشکلات متفاوتی می‌بینید که با کمی جستجو می‌تونید مشکل رو حل کنید مثلا Android toolchain هم یکی دیگه از مواردی هست که ممکنه اذیت کنه و چند مشکل دیگه
بهترین روش جستجو هستش من توی این مورد خیلی اذیت شدم و این راهکار جواب داد، امیدوارم به شما هم کمک کنه.

اگر از این روش جواب نگرفتید می‌تونید کامنت بزارید شاید بتونم کمکتون کنم.

سپاس بیکران.

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *